Go to Home, Setup, Modules, then to the "Deploy/install external app/module" tab. Upload the zip, then enable the module in the list. If the upload is refused, the Dolibarr custom folder is not writable. In that case, copy the folder from the zip into htdocs/custom over FTP or SSH.